import re
regex = re.compile(r"^\+(\d{3}|\d{2}|\d{1})\s\((\d{3}|\d{2}|\d{1})\)\s(\d{3}|\d{2}|\d{1})\-(\d{2}|\d{1})\-(\d{2}|\d{1})", flags=re.MULTILINE)
test_str = ("+189 (377) 123-12-34\n\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")