import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{4,10}$)\\S.*\\S$";
final String string = "Test\n"
+ "Test Test\n"
+ "Test-Test\n"
+ "Test'Test\n"
+ "Test,Test\n"
+ " \n"
+ " \n"
+ " Test \n"
+ "12\n"
+ "12345678901";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}