re = /^(?=.{4,10}$)\S.*\S$/m
str = 'Test
Test Test
Test-Test
Test\'Test
Test,Test
Test
12
12345678901'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end