$re = '/^(?=.{4,10}$)\S.*\S$/m';
$str = 'Test
Test Test
Test-Test
Test\'Test
Test,Test
Test
12
12345678901';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);