import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*[-+.'\\w]+@\\w+(?:[-.]\\w+)*\\.(?!co\\s*$)[a-z]{2,}\\s*$";
final String string = "yes@no.com\n"
+ "dfgdd@dghdfg.co.uk\n"
+ "dfg dfg\n"
+ "dfgdfd@gmail.co\n"
+ "dfgdfd@gmail.co \n"
+ "john@hotmail.com ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}