const regex = /^\s*[-+.'\w]+@\w+(?:[-.]\w+)*\.(?!co\s*$)[a-z]{2,}\s*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*[-+.\'\\w]+@\\w+(?:[-.]\\w+)*\\.(?!co\\s*$)[a-z]{2,}\\s*$', 'gm')
const str = `yes@no.com
dfgdd@dghdfg.co.uk
dfg dfg
dfgdfd@gmail.co
dfgdfd@gmail.co
john@hotmail.com `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}