import Foundation
let pattern = #"^\s*[-+.'\w]+@\w+(?:[-.]\w+)*\.(?!co\s*$)[a-z]{2,}\s*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
yes@no.com
dfgdd@dghdfg.co.uk
dfg dfg
dfgdfd@gmail.co
dfgdfd@gmail.co
john@hotmail.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)