#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b\d+\s+[A-Z]{3}\s+[A-Z]"
Local $sString = " 1 -1 2 SER HA H 4.477 0.003 1" & @CRLF & _
" 2 -1 2 SER HB2 H 3.765 0.001 1" & @CRLF & _
" 3 -1 2 SER HB3 H 3.765 0.001 1" & @CRLF & _
" 4 -1 2 SER C C 173.726 0.2 1" & @CRLF & _
" 5 -1 2 SER CA C 58.16 0.047 1" & @CRLF & _
" 6 -1 2 SER CB C 64.056 0.046 1" & @CRLF & _
" 7 0 3 HIS H H 8.357 0.004 1" & @CRLF & _
" 8 0 3 HIS HA H 4.725 0.003 1" & @CRLF & _
" 9 0 3 HIS HB2 H 3.203 0.003 2" & @CRLF & _
" ....." & @CRLF & _
" 63 7 10 GLU HA H 4.328 0.004 1" & @CRLF & _
" 64 7 10 GLU HB2 H 2.154 0.005 2" & @CRLF & _
" 65 7 10 GLU HB3 H 2.156 0.004 2" & @CRLF & _
" 66 7 10 GLU HG2 H 2.262 0.014 2" & @CRLF & _
" 67 7 10 GLU HG3 H 2.464 0.001 2" & @CRLF & _
" 68 7 10 GLU C C 177.242 0.2 1" & @CRLF & _
" 69 7 10 GLU CA C 59.009 0.068 1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")