import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d+\\s+[A-Z]{3}\\s+[A-Z]";
final String string = " 1 -1 2 SER HA H 4.477 0.003 1\n"
+ " 2 -1 2 SER HB2 H 3.765 0.001 1\n"
+ " 3 -1 2 SER HB3 H 3.765 0.001 1\n"
+ " 4 -1 2 SER C C 173.726 0.2 1\n"
+ " 5 -1 2 SER CA C 58.16 0.047 1\n"
+ " 6 -1 2 SER CB C 64.056 0.046 1\n"
+ " 7 0 3 HIS H H 8.357 0.004 1\n"
+ " 8 0 3 HIS HA H 4.725 0.003 1\n"
+ " 9 0 3 HIS HB2 H 3.203 0.003 2\n"
+ " .....\n"
+ " 63 7 10 GLU HA H 4.328 0.004 1\n"
+ " 64 7 10 GLU HB2 H 2.154 0.005 2\n"
+ " 65 7 10 GLU HB3 H 2.156 0.004 2\n"
+ " 66 7 10 GLU HG2 H 2.262 0.014 2\n"
+ " 67 7 10 GLU HG3 H 2.464 0.001 2\n"
+ " 68 7 10 GLU C C 177.242 0.2 1\n"
+ " 69 7 10 GLU CA C 59.009 0.068 1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}