# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b\d+\s+[A-Z]{3}\s+[A-Z]"
test_str = (" 1 -1 2 SER HA H 4.477 0.003 1\n"
" 2 -1 2 SER HB2 H 3.765 0.001 1\n"
" 3 -1 2 SER HB3 H 3.765 0.001 1\n"
" 4 -1 2 SER C C 173.726 0.2 1\n"
" 5 -1 2 SER CA C 58.16 0.047 1\n"
" 6 -1 2 SER CB C 64.056 0.046 1\n"
" 7 0 3 HIS H H 8.357 0.004 1\n"
" 8 0 3 HIS HA H 4.725 0.003 1\n"
" 9 0 3 HIS HB2 H 3.203 0.003 2\n"
" .....\n"
" 63 7 10 GLU HA H 4.328 0.004 1\n"
" 64 7 10 GLU HB2 H 2.154 0.005 2\n"
" 65 7 10 GLU HB3 H 2.156 0.004 2\n"
" 66 7 10 GLU HG2 H 2.262 0.014 2\n"
" 67 7 10 GLU HG3 H 2.464 0.001 2\n"
" 68 7 10 GLU C C 177.242 0.2 1\n"
" 69 7 10 GLU CA C 59.009 0.068 1")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.