$re = '/(?<=ID:\s)(.{17})/';
$str = 'Hi there, my name is John Doe. I made a purchase and I\'m having issues with it. Transaction ID: 7FB54205R7031312B.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);