re = /(?<=ID:\s)(.{17})/
str = 'Hi there, my name is John Doe. I made a purchase and I\'m having issues with it. Transaction ID: 7FB54205R7031312B.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end