import Foundation
let pattern = #"(?<=ID:\s)(.{17})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Hi there, my name is John Doe. I made a purchase and I'm having issues with it. Transaction ID: 7FB54205R7031312B."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)