#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.).*\1"
Local $sString = "156.48.459.20 - - [11/Aug/2019" & @CRLF & _
"156.48.459.20 - - [11/Aug/2019" & @CRLF & _
"235.145.41.12 - - [11/Aug/2019" & @CRLF & _
"235.145.41.12 - - [11/Aug/2019" & @CRLF & _
"66.23.114.251 - - [11/Aug/2019"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")