import re
regex = re.compile(r"(.).*\1", flags=re.MULTILINE)
test_str = ("156.48.459.20 - - [11/Aug/2019\n"
"156.48.459.20 - - [11/Aug/2019\n"
"235.145.41.12 - - [11/Aug/2019\n"
"235.145.41.12 - - [11/Aug/2019\n"
"66.23.114.251 - - [11/Aug/2019")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")