re = /(.).*\1/m
str = '156.48.459.20 - - [11/Aug/2019
156.48.459.20 - - [11/Aug/2019
235.145.41.12 - - [11/Aug/2019
235.145.41.12 - - [11/Aug/2019
66.23.114.251 - - [11/Aug/2019'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end