package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(BE)[1-9]{2}(-?)[0-9]{4}(-?)[0-9]{4}(-?)[0-9]{4}`)
var str = `BE15-7878-0144-5741
BE15001470142457
BE1235-16152-216510-152615620
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}