const regex = /(BE)[1-9]{2}(-?)[0-9]{4}(-?)[0-9]{4}(-?)[0-9]{4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(BE)[1-9]{2}(-?)[0-9]{4}(-?)[0-9]{4}(-?)[0-9]{4}', 'gm')
const str = `BE15-7878-0144-5741
BE15001470142457
BE1235-16152-216510-152615620
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}