using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"T\d{4}/\d{4}(*SKIP)(*F)|\d{4}[AB]?[CD]?";
string input = @"Some text T7878/6767 1234AB and some more text";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}