$re = '~T\d{4}/\d{4}(*SKIP)(*F)|\d{4}[AB]?[CD]?~';
$str = 'Some text T7878/6767 1234AB and some more text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);