re = /T\d{4}\/\d{4}(*SKIP)(*F)|\d{4}[AB]?[CD]?/
str = 'Some text T7878/6767 1234AB and some more text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end