using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/frontend\/([\w]+)\/?([0-9]+)?\/?";
string input = @"/frontend/ajax_adasd/123,asdzxcvzxcvasdf";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}