re = /\/frontend\/([\w]+)\/?([0-9]+)?\/?/i
str = '/frontend/ajax_adasd/123,asdzxcvzxcvasdf'
# Print the match result
str.match(re) do |match|
puts match.to_s
end