#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?(?=\s+)|(?(?=\w\))(?<a>\w\).*)|(?<q>.*?\n)))"
Local $sString = "pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta" & @CRLF & _
"" & @CRLF & _
"pergunta quanto é pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta" & @CRLF & _
"" & @CRLF & _
" a) resposta a" & @CRLF & _
"" & @CRLF & _
" b) resposta b " & @CRLF & _
"" & @CRLF & _
" c) resposta c" & @CRLF & _
"" & @CRLF & _
" d) resposta d" & @CRLF & _
"" & @CRLF & _
" e) resposta e" & @CRLF & _
"" & @CRLF & _
" _) respsota _"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")