const regex = /(?(?=\s+)|(?(?=\w\))(?<a>\w\).*)|(?<q>.*?\n)))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(?=\\s+)|(?(?=\\w\\))(?<a>\\w\\).*)|(?<q>.*?\\n)))', 'g')
const str = `pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta
pergunta quanto é pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta
a) resposta a
b) resposta b
c) resposta c
d) resposta d
e) resposta e
_) respsota _`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}