re = /(?(?=\s+)|(?(?=\w\))(?<a>\w\).*)|(?<q>.*?\n)))/
str = 'pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta
pergunta quanto é pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta pergunta
a) resposta a
b) resposta b
c) resposta c
d) resposta d
e) resposta e
_) respsota _'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end