using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^,?\d\d?(?:,\d\d?)*,?$";
string input = @"01,23,05,1,28,25
,01,23,05,1,28,25,
01,23,05,1,28,25,
01,23,05,1,28,25";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}