package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^,?\d\d?(?:,\d\d?)*,?$`)
var str = `01,23,05,1,28,25
,01,23,05,1,28,25,
01,23,05,1,28,25,
01,23,05,1,28,25`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}