$re = '/^,?\d\d?(?:,\d\d?)*,?$/m';
$str = '01,23,05,1,28,25
,01,23,05,1,28,25,
01,23,05,1,28,25,
01,23,05,1,28,25';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);