import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\{\\{([\\w-]+(?: [\\w-]+)*)|\\G(?!$))(?:\\h+\\[([^]]+)\\])?(?=.*\\})";
final String string = "{{word with spaces}}\n"
+ "{{word with spaces [sub1]}\n"
+ "{{word with spaces [sub1] [sub 2] [Sub-3] }}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}