$re = '/(?:{{([\w-]+(?: [\w-]+)*)|\G(?!$))(?:\h+\[([^]]+)\])?(?=.*})/m';
$str = '{{word with spaces}}
{{word with spaces [sub1]}
{{word with spaces [sub1] [sub 2] [Sub-3] }}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);