using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/[a-z]{1,}\.[a-z]{1,}(\.[a-z]{1,})+";
string input = @"https://www.abnamro.nl.co.uk
http://www.abnamro.nl";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}