package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?:\/\/[a-z]{1,}\.[a-z]{1,}(\.[a-z]{1,})+`)
var str = `https://www.abnamro.nl.co.uk
http://www.abnamro.nl`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}