#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^,]"
Local $sString = "this is " & @CRLF & _
", " & @CRLF & _
"" & @CRLF & _
"a comma , " & @CRLF & _
"" & @CRLF & _
"and the ,,,,,rest " & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)