$re = '/[^,]/';
$str = 'this is
,
a comma ,
and the ,,,,,rest
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;