package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^,]`)
var str = `this is
,
a comma ,
and the ,,,,,rest
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}