import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<span>)(.|\\n)*?(?=<\\/span>)";
final String string = "<span>\n"
+ " Do not use hard returns to break lines; use the word wrap feature.\n"
+ " </span>\n"
+ " <span>\n"
+ " The\n"
+ " <strong>abstract paragraph</strong>\n"
+ " cannot exceed 250 words. A maximum of 2 tables and/or figures are acceptable. Deduct 50 words from the maximum word count for each included table or figure. Figures\n"
+ " should be no larger than 3.5 inches wide by 4.0 inches high, legible at these dimensions, and cropped to eliminate extra white space. Tables must fit and be legible\n"
+ " within a 3.5 inch column.\n"
+ " </span>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}