import re
regex = re.compile(r"(?<=<span>)(.|\n)*?(?=<\/span>)", flags=re.MULTILINE)
test_str = ("<span>\n"
" Do not use hard returns to break lines; use the word wrap feature.\n"
" </span>\n"
" <span>\n"
" The\n"
" <strong>abstract paragraph</strong>\n"
" cannot exceed 250 words. A maximum of 2 tables and/or figures are acceptable. Deduct 50 words from the maximum word count for each included table or figure. Figures\n"
" should be no larger than 3.5 inches wide by 4.0 inches high, legible at these dimensions, and cropped to eliminate extra white space. Tables must fit and be legible\n"
" within a 3.5 inch column.\n"
" </span>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")