using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<quote>['""])(?:(?!\k<quote>).)*\k<quote>";
string input = @"stuff ""Something"" stuff
stuff 'something' stuff
stuff ""Today's Top 10"" stuff
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}