re = /(?<quote>['"])(?:(?!\k<quote>).)*\k<quote>/m
str = 'stuff "Something" stuff
stuff \'something\' stuff
stuff "Today\'s Top 10" stuff
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end