#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bEmail[^:]*:\s*([^\s@]+@[^\s@]+)"
Local $sString = "Submitted data:" & @CRLF & _
"First Name: MyName" & @CRLF & _
"Your Email Address: email@domain.com" & @CRLF & _
"TAG:" & @CRLF & _
"" & @CRLF & _
"Submitted data:" & @CRLF & _
"First name: MyName" & @CRLF & _
"Last name:" & @CRLF & _
"Email: email@domain.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")