$re = '/\bEmail[^:]*:\s*([^\s@]+@[^\s@]+)/';
$str = 'Submitted data:
First Name: MyName
Your Email Address: email@domain.com
TAG:
Submitted data:
First name: MyName
Last name:
Email: email@domain.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);