// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bEmail[^:]*:\s*([^\s@]+@[^\s@]+)").unwrap();
let string = "Submitted data:
First Name: MyName
Your Email Address: email@domain.com
TAG:
Submitted data:
First name: MyName
Last name:
Email: email@domain.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}