const regex = new RegExp('(?<=No_23\\">)[^;]+', 'gm')
const str = `;abcde;No_22">123456;No_23">Apple Pie;No_24">New York;No_25">Qyt 4;>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}