re = /(?<=No_23\">)[^;]+/m
str = ';abcde;No_22">123456;No_23">Apple Pie;No_24">New York;No_25">Qyt 4;>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end