import re
regex = re.compile(r"(?<=No_23\">)[^;]+", flags=re.MULTILINE)
test_str = ";abcde;No_22\">123456;No_23\">Apple Pie;No_24\">New York;No_25\">Qyt 4;>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")