using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!\w*([sar])\w*\1)(?!(?:\w*t){3})[sart]{3,}\b";
string input = @"rar sas aaa rtt at sit start, tarts, arts, art ttt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}