re = /\b(?!\w*([sar])\w*\1)(?!(?:\w*t){3})[sart]{3,}\b/m
str = 'rar sas aaa rtt at sit start, tarts, arts, art ttt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end