#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z]{1,7}+(?:[A-Z]\d?)?$"
Local $sString = "S3" & @CRLF & _
"FT5" & @CRLF & _
"FGTU7" & @CRLF & _
"ERTYUOP9" & @CRLF & _
"ERTGHYUKM" & @CRLF & _
"Correspond to:" & @CRLF & _
"" & @CRLF & _
"E" & @CRLF & _
"ERT" & @CRLF & _
"RTYUKL" & @CRLF & _
"VBNDEFRW3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")