import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z]{1,7}+(?:[A-Z]\\d?)?$";
final String string = "S3\n"
+ "FT5\n"
+ "FGTU7\n"
+ "ERTYUOP9\n"
+ "ERTGHYUKM\n"
+ "Correspond to:\n\n"
+ "E\n"
+ "ERT\n"
+ "RTYUKL\n"
+ "VBNDEFRW3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}